Бета тестирование. Бесплатное.

Сообщений: 120 / 0 новое
Последнее сообщение
Stepan
Не в сети
Зарегистрирован: 19.09.2010

Хочу протестировать Ваш middleware для DIB-120. Провайдер Ниеншанц-Хоум. Для него шаблон каналов уже есть?

Stepan
Не в сети
Зарегистрирован: 19.09.2010

При подключении по HDMI с разрешением 720P и соотношением сторон 16:9 видео в превью уезжает в право и в низ.

Для этого режима у меня правельное положение будет таким:
var WinWidth=445;
var WinHeight=270;
var WinX=687;
var WinY=65;
stb_media.setPIG(true,WinWidth,WinHeight,WinX,WinY);

Stepan
Не в сети
Зарегистрирован: 19.09.2010

При выборе режима ТВ: 720P - после перезагрузки показывает режим ТВ: 720P-24HZ.
При выборе режима ТВ: 1080P-30Hz - после перезагрузки показывает режим ТВ: 720P

При этом info по разрешению на самом ТВ показывает правильное разрешение - которое выбирается.

skylord
Не в сети
Зарегистрирован: 26.06.2010

1) Для Ниеншанца шаблон есть. Не уверен насчет его актуальности, т.к. его не мы поддерживаем, но какой-то есть...

2) Да, в курсе про этот баг. Там просто все цифровые режимы считались по пропорциям 1080, а у 720 пропорции другие... Поправлен в новой версии, которая будет, скорее всего, уже сегодня. Сейчас еще немного потестируем и сделаем сборку - следите за новостями.

3) Спасибо за информацию. Данные о режимах мы берем из D-Link'овского API - там написано так, как есть у нас. Сейчас перед релизом уже менять ничего не будем, а в следующей версии (будет, очевидно, багфиксовая через пару дней по результатам тестирования пользователями - обязательно что-нибудь найдут, что мы не увидели) перепроверим вручную и назовем правильно. Заодно, наверное, и многочисленные разновидности PAL/NTSC уберем - все равно они не нужны никому....

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

поставил прошивку, добавил список каналов, но вот теперь проблема, включаю приставку пишет, что не может подключиться к серверу, ну это и понятно IP адресс стоит локальный, пытаюсь изменить его, но после перезагрузки он ставит тот же IP который был, как быть в таком случае?

skylord
Не в сети
Зарегистрирован: 26.06.2010

Вы уже в почту написали - будем в почте разбираться... Вообще, странно. Мы статику проверяли - нормально работает. И тут на форуме тоже кто-то отписывался, что нормально все было.

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

спасибо за уделённое время, пообщались приятно, думаю эта проблема скоро решиться...
Желаю удачи в вашем проекте...

intelmedia
Не в сети
Зарегистрирован: 12.08.2010

С IP всё нормально, проблем не возникало. Небольшая опечатка, в прошивке написано EPG - инфо, а у меня на пульте инфо вызывается кнопкой OSD. И радио так и не получилось у меня заставить работать...

skylord
Не в сети
Зарегистрирован: 26.06.2010

1) Спасибо за отзыв насчет IP.

2) Да, про опечатку знаем - про это сразу же написал в соответствующей ветке. Просто уже была готова сборка, когда заметили.

3) Ту ссылку, которую вы тогда давали, проиграть и не получится, насколько я помню. Радио должно быть точно таким же потоком, как видео, только без видео дорожки. Со спутников как раз такие гонят.

intelmedia
Не в сети
Зарегистрирован: 12.08.2010

У нас на прошивке провайдера на этой приставке так играет.. Есть поток udp://239.0.0.127:1234 и на нём несколько звуковых дорожек, значащихся как 4110,4170,4143...и т.д. Так и пробовал добавлять.

skylord
Не в сети
Зарегистрирован: 26.06.2010

Гм. Тогда действительно должно играть. А что именно происходит? Должен быть просто черный экран и звук, соответственно. Звука нет? Попробуйте не добавлять звуковых дорожек, чтобы приставка автоматически играла первую, а не переключалась на ту, которую вы укажете - может с этим связано...

intelmedia
Не в сети
Зарегистрирован: 12.08.2010

Звука нет. Поудалял звуковые дорожки - то же самое.. Хотя смотрю в этот момент на роутере - поток в 1Мбит тянет, а звука нет...

skylord
Не в сети
Зарегистрирован: 26.06.2010

А кодек какой? Можете записать поток в TS (например, через VLC) и прислать на почту (или выложите где-нибудь - скачаю)? Надо бы посмотреть, что приставка в консоль говорит от этого потока...

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

что нибудь решилось по моему вопросу? И ещё 1 вопрос, реализовано ли у вас переключение на 2-ух и 3-ёх значные каналы по нажатию цифр на пульте?

skylord
Не в сети
Зарегистрирован: 26.06.2010

Ну вот, буквально пару сообщений выше пользователь написал, что у него статика нормально работает. Мы у себя пока тоже воспроизвести не смогли, поэтому пока еще результата никакого нет...

Конечно реализовано. :-) Вы же прошивку ставили - неужели не увидели? В скине по умолчанию есть место только для 3-х цифр, но технически проблем никаких - если надо больше, то скин можно без проблем поправить...

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

ну прошивка прошивкой, а запустить канал так и не получилось

skylord
Не в сети
Зарегистрирован: 26.06.2010

Ааа... Из-за этих проблем со статикой... Вы, кстати, так и не описали схему подключения. У вас приставка как к сети подключена? Там по DHCP ничего не выдается вообще? Обычно все подключают через роутеры и им статика эта вообще не нужна.

Stepan
Не в сети
Зарегистрирован: 19.09.2010

При подключении приставки через HDMI интерфейс к ТВ, приставка пару минут не корректно реагирует на команды ПДУ после on/off ТВ или перезагрузки приставки.

skylord
Не в сети
Зарегистрирован: 26.06.2010

Некорректно - это как? Что именно происходит при нажатия на какие конкретно кнопки пульта? После перезагрузки все проходит?

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

используем в сети, по dhcp выдаётся IP, но проблема в том, что выдаётся свободный IP не заведённый к инету, по этому как бы и не могу подключиться

skylord
Не в сети
Зарегистрирован: 26.06.2010

А если статически прописать, то интернет будет? Привязок MAC-IP в сети разве нет? Через роутер не хотите попробовать подключить?

sSsantasSs
Не в сети
Зарегистрирован: 22.09.2010

1) статику прописываю, но почему то сразу всё скидывается на автоматически
2) привязки конечно есть, но тех директор на фряху не пускает...
3) через роутер не хотим, мы тестируем именно в уловиях абонента

skylord
Не в сети
Зарегистрирован: 26.06.2010

Нашли баг в настройках сети. Уже поправили. Ждите следующего релиза (полагаю, в начале следующей недели) - там же будут и запароленые каналы.

Спасибо за сообщение об ошибке!

xuma
Не в сети
Зарегистрирован: 12.07.2010

Обнаружен небольшой баг, 

после указания статических параметров сети, если заглушить сервер, где лежит файл со списком каналов и программой передач, то шлюз переходит в состояние 0.0.0.0 

после того как подняли сервер, подхватывается список каналов и программа передач, но UDP трафик не идет из-за отсутствия шлюза, приходиться вновь его вводить...


skylord
Не в сети
Зарегистрирован: 26.06.2010

Это не с сервером все-таки проблема, а, скорее всего, именно с настройками статики - как у другого пользователя в этой ветке было. Нашли и поправили вчера. Скоро будет багфикс.

ant001
Не в сети
Зарегистрирован: 03.12.2010

Привет,
подумываю о покупке приставки, проверил в ВЛС, все совпадает, кроме расположения, там "rtp://@224.1.43.14:1234", будет работать?

skylord
Не в сети
Зарегистрирован: 26.06.2010

Должно в последней версии прошивки. Посмотрите в соседней ветке про нее - там есть положительный отзыв по работе с RTP. Для гарантии можете еще скинуть, что у вас VLC выдает в информации о потоке.

RTP только в последней версии ядра добавили поэтому еще мало статистики...

nikello
Не в сети
Зарегистрирован: 11.02.2011

rtp работать будет
проверено, на новой прошивке 4.06.010

skylord
Не в сети
Зарегистрирован: 26.06.2010

Да оно еще на предыдущей работало - на форуме люди уже отписывались. :-)